Back to overview
Resolved
iPlato - Toolbar service issues
Jul 20, 2026 at 10:37am UTC
Affected services
iPlato Toolbar
Resolved
Jul 20, 2026 at 10:57am UTC
We have identified the issue and the iPlato Toolbar services are back up and running.
If you are still experiencing issues, please contact help@iplato.com
Affected services
Created
Jul 20, 2026 at 10:37am UTC
We are currently experiencing issues on iPlato impacting the Toolbar. Our engineering teams are aware of the issue and are working urgently to restore full functionality. We will provide another update as soon as we have more information.
Affected services