Unable to login to iPlato
Resolved
Jul 17, 2026 at 2:26pm UTC
The fix has now applied and services have been restored.
Please attempt to login again and if you continue to experience any issues, please contact support.
Affected services
Updated
Jul 17, 2026 at 2:22pm UTC
The root cause has been identified and we are actively deploying the required remedial actions.
We expect these changes to fully address the issue and will continue to monitor the situation closely to ensure service stability.
Affected services
Created
Jul 17, 2026 at 2:15pm UTC
We are aware of an issue affecting iPlato Connect and Toolbar.
The team are currently investigating to identify the root cause.
Affected services