Back to overview
Resolved

iPLATO system down

Jun 29, 2026 at 9:21am UTC
Affected services
iPlato Toolbar
iPlato

Resolved
Jun 29, 2026 at 9:49am UTC

We have resolved the issue that was affecting users within the Toolbar.

Please retry any SMS messages that failed to send while the issue was ongoing.

If you continue to experience any problems, please contact our Support team and we'll be happy to help.

Created
Jun 29, 2026 at 9:21am UTC

We are currently experiencing issues on iPlato impacting the Toolbar. Our engineering teams are aware of the issue and are working urgently to restore full functionality. We will provide another update as soon as we have more information.

We apologise for the inconvenience and appreciate your patience.