Back to overview
Resolved
Something went wrong error when accessing Connect
Apr 20, 2026 at 7:44am UTC
Affected services
Connect Platform
Resolved
Apr 20, 2026 at 8:11am UTC
The issue affecting access to the Connect platform has now been identified and fixed.
If you continue to have issues please reach out to support.
Affected services
Created
Apr 20, 2026 at 7:44am UTC
We are currently investigating an issue with accessing our Connect Platform. When accessing, users are presented with a 'Something went wrong' error.
Our Engineering team are currently investigating.
Affected services