Back to overview
Degraded

iPlato support down

Oct 20 at 09:47am BST
Affected services
iPlato

Resolved
Oct 20 at 11:17am BST

Our customer support system is back up and running and the team are working through conversations, please continue to email your request to help@iplato.com.

Created
Oct 20 at 09:47am BST

Our customer support system is currently experiencing a full server outage affecting our ability to provide immediate support.

The provider is working to resolve the issue as quickly as possible, and we will resume normal services as soon as the system is fully operational.

In the meantime, please email your request to help@iplato.com. The team is monitoring this mailbox and will address all queries as soon as our full support system is back online.