Back to overview
Degraded

iPlato Toolbar - failed emails

Aug 01 at 10:48am BST
Affected services
iPlato Toolbar

Resolved
Aug 01 at 12:26pm BST

On Thursday, July 31st, 2025, we received reports of a high number of failed emails. Our engineering team successfully resolved this issue this morning, and emails are now sending without interruption.
To check any failed emails please head to mygpconnect.com > Inbox > Sent and filter by Failed. These emails will then need to be sent again.
Apologies for any inconvenience this has caused. Any questions or support please email help@iplato.com

Created
Aug 01 at 10:48am BST

On Thursday, July 31st, 2025, we received reports of a high number of failed emails. Our engineering team successfully resolved this issue this morning, and emails are now sending without interruption.
To check any failed emails please head to mygpconnect.com > Inbox > Sent and filter by Failed. These emails will then need to be sent again.
Apologies for any inconvenience this has caused. Any questions or support please email help@iplato.com